Jump to content

Recommended Posts

@wenke

Danke, guter Tip das mit dem + hinter der Klammer.

@Excel-Götter

Ich kämpfe schon wieder mit dem nächsten Problem. Vielleicht ist die Lösung sogar schon irgendwo gepostet und ich finde/kapiere sie nur nicht, aber es wird für Anfänger auch etwas unübersichtlich. Was kein Gemecker sein soll, macht hübsch weiter so.

Also: Ich habe eine Auswertung auf EC erstellt. Nun möchte ich, sobald in der Saldospalte ein Wert größer 0 steht, das dieser Wert in einer gesonderten Spalte ausgewiesen und die Auswertung neu gestartet wird, wobei der letzte Coup als Vorlaufcoups Berücksichtigung finden soll.

Meine bisherigen Versuche führten entweder zu Fehlermeldungen in den folgenden Spalten oder der Wert wurde zwar ausgewiesen, die Auswertung aber lief einfach mit dem Saldo weiter. Ich habe mir erstmal damit beholfen das ich bei einem + ein neues Tabellenblatt angelegt und die Partie neu gestartet habe, aber das kann es doch eigentlich nicht sein.

Warte schon gespannt auf eure Lösungsvorschläge.

Die Beschäftigung mit dieser Excel-Geschichte ist echt Pulver für's Hirn.

Shotgun

******

bearbeitet von Wenke
Link zum Beitrag
Auf anderen Seiten teilen

Hallo shotgun,

werde mal wieder versuchen, einen Vorschlag zu unterbreiten. Hoffe, diesmal ist er nicht zu kompliziert :lol:

Gut, gehen wir mal davon aus, dass du in der Spalte D deine Saldoformel stehen hast.

Diese Formel wird nun mit einer Wenn-Bedingung "ummandelt", hier die Formel für Zeile D2:

=wenn(D1>0;0;deine bisherige Formel)

Im Grund genommen ganz einfach, wenn der Saldo in der vorhergehenden Zeile größer als 0 ist, dann wird wieder bei 0 gestartet, ansonsten kommt deine bisherige Formel zum Einsatz.

So nun benötigen wir eine Spalte (ich nehme mal E) für den bisherigen Saldenwert. Hier die Formel für Zeile E1:

=wenn(D1>0;d1;0)

Also auch ganz einfach, wenn Saldo in der Saldenspalte größer 0 ist, dann wird der Saldenwert übertragen, ansonsten stellen wir ein 0 ein.

Jetzt zur Verwendung des Vorlaufcoups für die Ermittlung des Saldos. Ich gehe mal davon aus, dass du in Spalte B eine Formel zur Ermittlung eines Favoriten oder ähnliches stehen hast. Das heißt, du mußt möglich Zähler wieder auf Null setzen, wenn in der vorhergehenden Zeile ein Saldo größer als 0 vorkommt. Also Formel in B2:

=wenn(D1>0;zähler auf 0 oder was auch immer;bisherige Formel)

Da ich deine Auswertung nicht kenne, ist es schwer, dir zu helfen. Also bitte stelle mal die Formeln aus den jeweiligen Spalten ein, die dir Schwierigkeiten bereiten.

Ich hoffe, ich konnte dir helfen, wenn nicht, dann bitte die Frage etwas genauer (mit Formeln) stellen.

Danke

******

bearbeitet von Wenke
Link zum Beitrag
Auf anderen Seiten teilen

Hilfe!!!

Bin mit dem Problem aus meinem letzten posting leider immer noch nicht weiter, obwohl ich nochmal zwei Tage 'rumprobiert habe.

Ich füge mal meine aktuelle Geschichte ein und beschreibe dann unten noch mal genau meine Probleme und auch die Formeln, die den Problemspalten hinterlegt sind.

<pre>

Coup Zahl Noir Pair N/P Satz Saldo

1 33 X +/-

2 21 -- 2 -2 2 26

3 31 X +/- 2 -2 2 26

4 35 X +/- 2 -2 2 26

5 12 X +/- 2 -2 2 26

6 26 X X + 2 0 2 26

7 13 X +/- 2 0 2 26

8 14 X +/- 2 0 2 26

9 19 -- 2 -2 2 26

10 31 X +/- -2 2 26

11 30 X +/- 2 -2 2 26

12 16 X +/- 2 -2 2 26

13 6 X X + -2 2 26

14 4 X X + 2 0 2 26

15 12 X +/- 2 0 2 26

16 34 X +/- 2 0 2 26

17 25 -- 0 2 26

18 17 X +/- 0 2 26

19 26 X X + 2 2 2 26

20 9 -- 2 0 2 26

21 0 0 0 0 2 -1 2 26

22 8 X X + 2 1 2 26

23 31 X +/- 2 1 2 26

24 14 X +/- 2 1 2 26

25 19 -- 2 -1 2 26

26 28 X X + -1 2 26

27 32 X +/- 2 -1 2 26

28 6 X X + 2 1 2 26

29 26 X X + 2 3 2 26

30 1 -- 2 1 2 26

31 4 X X + 2 3 2 26

32 13 X +/- 2 3 2 26

33 17 X +/- 2 3 2 26

34 13 X +/- 2 3 2 26

35 17 X +/- 2 3 2 26

36 4 X X + 2 5 2 26

37 35 X +/- 2 5 2 26

38 23 -- 2 3 2 26

39 32 X +/- 2 3 2 26

40 20 X X + 3 2 26

41 14 X +/- 2 3 2 26

42 26 X X + 2 5 2 26

43 6 X X + 2 7 2 26

44 21 -- 2 5 2 26

45 28 X X + 2 7 2 26

46 10 X X + 2 9 2 26

47 10 X X + 2 11 2 26

48 31 X +/- 2 11 2 26

49 7 -- 2 9 2 26

50 27 -- 2 7 2 26

51 31 X +/- 7 2 26

52 8 X X + 2 9 2 26

53 13 X +/- 2 9 2 26

54 14 X +/- 2 9 2 26

55 33 X +/- 2 9 2 26

56 31 X +/- 2 9 2 26

57 29 X +/- 2 9 2 26

58 30 X +/- 2 9 2 26

59 34 X +/- 2 9 2 26

60 23 -- 9 2 26

61 2 X X + 9 2 26

62 4 X X + 2 11 2 26

63 23 -- 2 9 2 26

64 24 X X + 2 11 2 26

65 4 X X + 2 13 2 26

66 33 X +/- 2 13 2 26

67 28 X X + 2 15 2 26

68 28 X X + 2 17 2 26

69 26 X X + 2 19 2 26

70 13 X +/- 2 19 2 26

71 23 -- 2 17 2 26

72 4 X X + 2 19 2 26

73 7 -- 2 17 2 26

74 13 X +/- 2 17 2 26

75 6 X X + 2 19 2 26

76 26 X X + 2 21 2 26

77 29 X +/- 2 21 2 26

78 30 X +/- 2 21 2 26

79 13 X +/- 2 21 2 26

80 25 -- 2 19 2 26

81 26 X X + 2 21 2 26

82 10 X X + 2 23 2 26

83 2 X X + 2 25 2 26

84 19 -- 2 23 2 26

85 36 X +/- 2 23 2 26

86 3 -- 23 2 26

87 17 X +/- 23 2 26

88 19 -- 2 21 2 26

89 9 -- 2 19 2 26

90 28 X X + 19 2 26

91 32 X +/- 2 19 2 26

92 23 -- 2 17 2 26

93 29 X +/- 17 2 26

94 7 -- 2 15 2 26

95 36 X +/- 2 15 2 26

96 34 X +/- 15 2 26

97 26 X X + 15 2 26

98 3 -- 2 13 2 26

99 20 X X + 2 15 2 26

100 29 X +/- 2 15 2 26

101 6 X X + 2 17 2 26

102 16 X +/- 2 17 2 26

103 11 X +/- 2 17 2 26

104 25 -- 2 15 2 26

105 20 X X + 2 17 2 26

106 31 X +/- 2 17 2 26

107 23 -- 2 15 2 26

108 18 X +/- 2 15 2 26

109 25 -- 15 2 26

110 6 X X + 15 2 26

111 0 0 0 0 2 14 2 26

112 16 X +/- 2 14 2 26

113 26 X X + 2 16 2 26

114 7 -- 2 14 2 26

115 2 X X + 2 16 2 26

116 1 -- 2 14 2 26

117 11 X +/- 2 14 2 26

118 0 0 0 0 2 13 2 26

119 3 -- 2 11 2 26

120 20 X X + 2 13 2 26

121 20 X X + 2 15 2 26

122 34 X +/- 2 15 2 26

123 6 X X + 2 17 2 26

124 36 X +/- 2 17 2 26

125 12 X +/- 2 17 2 26

126 16 X +/- 17 2 26

127 9 -- 17 2 26

128 27 -- 17 2 26

129 9 -- 17 2 26

130 32 X +/- 17 2 26

131 1 -- 17 2 26

132 15 X +/- 17 2 26

133 21 -- 2 15 2 26

134 36 X +/- 2 15 2 26

135 17 X +/- 15 2 26

136 12 X +/- 2 15 2 26

137 14 X +/- 2 15 2 26

138 31 X +/- 15 2 26

139 26 X X + 2 17 2 26

140 29 X +/- 2 17 2 26

141 11 X +/- 2 17 2 26

142 34 X +/- 2 17 2 26

143 3 -- 2 15 2 26

144 13 X +/- 15 2 26

145 22 X X + 2 17 2 26

146 27 -- 2 15 2 26

147 9 -- 2 13 2 26

148 18 X +/- 13 2 26

149 3 -- 13 2 26

150 11 X +/- 13 2 26

151 14 X +/- 2 13 2 26

152 22 X X + 2 15 2 26

153 0 0 0 0 2 14 2 26

154 8 X X + 2 16 2 26

155 4 X X + 2 18 2 26

156 13 X +/- 2 18 2 26

157 8 X X + 2 20 2 26

158 21 -- 2 18 2 26

159 21 -- 2 16 2 26

160 32 X +/- 16 2 26

161 30 X +/- 16 2 26

162 31 X +/- 16 2 26

163 12 X +/- 2 16 2 26

164 3 -- 2 14 2 26

165 33 X +/- 14 2 26

166 11 X +/- 2 14 2 26

167 15 X +/- 2 14 2 26

168 26 X X + 2 16 2 26

169 36 X +/- 2 16 2 26

170 18 X +/- 2 16 2 26

171 25 -- 16 2 26

172 19 -- 16 2 26

173 26 X X + 16 2 26

174 33 X +/- 2 16 2 26

175 5 -- 2 14 2 26

176 10 X X + 2 16 2 26

177 24 X X + 2 18 2 26

178 30 X +/- 2 18 2 26

179 1 -- 2 16 2 26

180 9 -- 16 2 26

181 30 X +/- 16 2 26

182 23 -- 16 2 26

183 33 X +/- 16 2 26

184 36 X +/- 2 16 2 26

185 19 -- 2 14 2 26

186 32 X +/- 14 2 26

187 0 0 0 0 14 2 26

188 13 X +/- 14 2 26

189 6 X X + 2 16 2 26

190 19 -- 2 14 2 26

191 20 X X + 2 16 2 26

192 13 X +/- 2 16 2 26

193 35 X +/- 2 16 2 26

194 14 X +/- 2 16 2 26

195 31 X +/- 2 16 2 26

196 9 -- 2 14 2 26

197 20 X X + 2 16 2 26

198 11 X +/- 2 16 2 26

199 11 X +/- 2 16 2 26

2 2 26

2 26

</pre>

In den letzten beiden Spalten ist eine Progression hinterlegt, gewöhnlich sind diese ausgeblendet.

Problem1: Wie zu erkennen ist möchte ich jeweils auf Noir/Pair setzen, sobald Noir erscheint. Nach einmaligem erscheinen von Rouge wird einmal nachgesetzt, danach ein erneutes Erscheinen von Noir abgewartet. Nun kommt mir aber immer mal die Zero in die Quere, irgendwann bestimmt auch mal als doppel- oder dreifachschlag. Wie kann ich der Satzspalte sagen, die Zero nicht zu beachten sondern trotzdem den nächsten Satz zu tätigen, natürlich auch wenn nach der Zero einmalig Rouge fällt? Zur Zeit mache ich das manuell, indem ich die Formel in der entsprechenden Zeile dem Vorgang anpasse, aber das kann es ja nicht sein.

Formel in Spalte Satz: =WENN(ODER(C3="X";C4="X");H5;"")

Problem 2: Sobald der Saldo im Plus ist, möchte ich gerne das er in einer weiteren Spalte ausgewiesen und eine neue Partie begonnen wird, wobei der letzte Coups als Vorlaufcoup genommen wird.

Formel in Spalte Saldo: =WENN(B5="";"";WENN(F5="";G4;WENN(E5="+";G4+F5;WENN(E5="--";G4-F5;WENN(E5="+/-";G4;WENN(E5=0;G4-F5/2;G4))))))

Hoffe, ihr werdet schlau aus meinem Pulver und könnt mir HELFEN!!! :lol:

Shotgun

******

bearbeitet von Wenke
Link zum Beitrag
Auf anderen Seiten teilen

Hallo Shotgun,

wieder mal einer meiner "komplizierten" Lösungsverschläge. Ich hoffe, du versteht sie trotzdem.

Zum 1. Problem:

Wenn ich dich richtig verstanden haben, denn hast du Probleme mit der Konstellation:

N-0-N = X-_-X

Das Problem ist nun, dass nach dem ersten N gesetzt werden soll und natürlich nach dem Erscheinen der 0 noch einmal. Mit deiner Abfrage "ODER(C3="X";C4="X")" erwischt du den Fall natürlich nicht. Der einfachste, schnellste und blödeste Trick ist nun, aus N-0-N ein N-N-N, also X-X-X zu machen. Wie geht das? Ganz einfach, indem du die Formel in der Spalte C auf die Abfrage

WENN(ODER(istschwarz(a3);und(c2="X";a3=0));"X";"")

erweiterst. Dann wird einfach das "X" aus der vorhergehenden Zeile (c2) übernommen, wenn der Coup (a3) eine 0 ist. Damit erschlägst du auch den Fall N-0-0-0-N. Ich hoffe, du versteht meinen Tipp. Damit musst du die Spalte Satz auch nicht anpassen. Die kann bleiben, wie sie ist.

Zum Problem 2:

Wir setzen in die Spalte J den positiven Saldo mit der Formel (erste Zeile J2):

wenn(g2>0;g2;"")

Ab der dritten Zeile, also J3, addieren wir:

wenn(g3>0;j2+g3;j2)

So, nun zur Saldenspalte G. Der aktuelle Saldo wird wieder auf 0 zurückgesetzt, wenn in der vorhergehenden Zeile ein positiver Saldo erreicht wurde, also ab Zeile G3 die Formel:

=WENN(B3="";"";wenn(g2>0;0;WENN(F5="";G4;WENN(E5="+";.....

So, wenn ich das mit dem Vorlaufcoup richtig verstanden haben, dann willst du bei einem Saldo größer 0 nur noch das "X" in dieser Zeile verwenden, aber nicht mehr das in der vorhergehenden Zeile. Dazu erweiterst du die Formel in Spalte Satz auf (Zeile F5):

=wenn(g4>0;wenn(c4="X";H5;"");WENN(ODER(C3="X";C4="X");H5;""))

Somit wird bei einem Saldo größer 0 in der vorhergehenden Zeile nur noch diese Zeile auf Noir abgefragt, ansonsten immer die zwei vorhergehenden Zeilen.

So, ich hoffe, ich konnte mich verständlich ausdrücken und habe dein Problem auch voll erfasst. :lol:

******

bearbeitet von Wenke
Link zum Beitrag
Auf anderen Seiten teilen

@Chi

Super, danke. Werde ich morgen gleich mal antesten, heute habe ich keinen Bock mehr. Ich versuche ja auch, mir Lösungen selbst zu erarbeiten, aber manchmal kommt man ohne den richtigen Tip einfach nicht weiter. Vor allem da die Hilfe unter Excel teilweise haarsträubend für Anfänger ist.

Stelle dir mal vor du wärst auf meiner Wissensstufe und dann schaue dir mal an was da zu SVERWEIS steht. Ich habe, nach x-maligem durchlesen, nur begriffen das es viele große Bahnhöfe gibt und wenn das Gefälle des Bahnhofsvorplatzes einen gewissen Grad hat kann man das Alter des Bahnhofsvorstehers errechnen. :lol:

Aber es wird nicht aufgegeben solange noch Pulver da ist

Shotgun

Link zum Beitrag
Auf anderen Seiten teilen

Hallo Shotgun,

ich mache dir in keiner Weise einen Vorwurf, dass du hier deine Fragen einstellst. Ich hoffe, es kommt nicht so rüber. Ich will nur, dass ihr begreift, dass Programmieren mehr ist als einige Formeln zu verstehen. Deshalb ist es auch notwendig, ein Posting mehr als zwei Minuten zu überfliegen. Es kommt darauf an, die Löschungsverschläge zu verstehen. Und das kann man am besten, wenn man sich Schritt für Schritt den Lösungsverschlag erarbeitet und die einzelnen Formeln mal mit verschiednen Parametern in Excel ausprobiert.

Deshalb war ich am Anfang etwas sauer, als meine ersten Lösungsvorschläge nur mit der lapidaren Antwort "Ist mir zu kompliziert" gekontert wurden. Ich habe dies als "der Text ist mir zu lang und in zwei Minuten kapiere ich das nicht" interpretiert. Aber ich habe daraus gelernt und versuche, mit weniger Erklärungstext und einfacheren Lösungen aufzuwarten.

Ansonsten gebe ich dir Recht, die Excel-Hilfe in Sachen Formeln ist für Leute mit Programmierkenntnissen gedacht. Auch ich habe bei manchen Erklärungen meine Schwierigkeiten. Deshalb mein Tipp, immer versuchen, die aufgeführten Beispiele selber zu testen und durch die Variationen der Parameter zu verstehen, wie eine Formel funktioniert.

Ansonsten nicht aufgeben, du bist schon sehr weit für einen "Anfänger" und ich habe keine Probleme damit, User in Sachen Excel zu unterstützen. Wobei es für mich natürlich schwer ist, den Wissenstand meines Gegenübers einzuschätzen und meine Antwort möglichst leicht verständlich zu formulieren.

******

bearbeitet von Wenke
Link zum Beitrag
Auf anderen Seiten teilen

@ Chi Lu Jung

Ich hoffe, es kommt nicht so rüber. Ich will nur, dass ihr begreift, dass Programmieren mehr ist als einige Formeln zu verstehen.

Genau! Denn wenn man die Syntax nicht versteht, mach es auch keinen Sinn zu Programmieren!

Trotzdem würde ich auch gerne (noch ein Mal) deine Hilfe in Anspruch nehmen!

Normalerweise, wenn ich die Einsätze Programmiere erstelle ich mir einfach eine Formel (z.B. für Martingale oder für d'Alembert). Nur auf der anderen Seite wäre es praktisch, wenn man eine Tabelle hätte, in der die Einsätze automatisch abgelesen werden, dann müsste man dort die Einsätze nur ändern, und nicht die ganze Formel (ich vermute, dass das mit einer Verweis-Formel funktioniert, weiß aber nicht genau wie, und die Excel-Hilfe ist auch keine große Hilfe)

So könnte meines Erachtens die Progressionstabelle aussehen:

1. Einsatz 1

2. Einsatz 2

3. Einsatz 4

4. Einsatz 8

5. Einsatz 16

Vielen Dank im Voraus

David Cooper :crazy:

Link zum Beitrag
Auf anderen Seiten teilen

@Hallo David Cooper

(ich vermute, dass das mit einer Verweis-Formel funktioniert, weiß aber nicht genau wie, und die Excel-Hilfe ist auch keine große Hilfe)

Der SVERWEIS ist die richtige Funktion. Der SVERWEIS ist Inhalt von Teil3 die schönen Formeln...

In Teil1 oder 2 wurde er glaube ich verständlich beschrieben.

Mit besten Grüßen

Wenke

Link zum Beitrag
Auf anderen Seiten teilen

Hallo David,

nachdem Wenke schon "ausführlich" geantwortet hat, wage ich es trotzdem den Versuch, seine Antwort zu toppen :crazy:

Also zuerst legst du dir eine Datei "Legende.xls" an und stellst diese in das Startverzeichnis von Excel (unter Excel 2000 ist das c:\windows\anwendungsdaten\microsoft\excel\xlstart). Du kannst auch ein zusätzliches Startverzeichns in "Extras -> Optionen", Seite "Allgemein" und dort Feld "Zusätzlicher Startordner" bestimmen. Die Datei Legende.xls wird nun beim Starten von Excel immer automatisch geöffnet. Somit hast du deine Progressionen immer zur Verfügung.

In der Legende.xls stellst du deine Progressionen mit den Strufen und den Werten ein. Hier ein Beispiel:

Formeln in den Zellen als QuickNotiz

" wurden durch ' ersetzt

m_point17.gif A B
1 Progession Martingale  
2 Stufe Wert
3 1 1
4 2 2
5 3 4
6 4 8
7 5 16
8    
9    
10 Progression Fibonacci  
11 Stufe Wert
12 1 1
13 2 1
14 3 2
15 4 3
16 5 5

Für die einzelnen Progressionen vergibst du nun Namen. Damit kannst du dann leichter über die SVERWEIS-Formel darauf zugreifen. Also z.B. für den Bereich A3:B7 (oranger Bereich) den Namen "Martingale" und für A12:B16 (hellgrüner Bereich) den Namen "Fibonacci". So, damit haben wir den ersten Schritt getan.

Nun mußt du nur in deiner Auswertungsdatei über SVERWEIS auf diese Namen Bezug nehmen. Hier mal ein Beispiel:

Formeln in den Zellen als QuickNotiz

" wurden durch ' ersetzt

m_point17.gif A B C D E
1   Martingale   Fibonacci  
2 Coups Prog-Stufe Wert Prog-Stufe Wert
3 33 1 1 1 1
4 33     1 1
5 6     1 1
6 13 2 2 2 1
7 9     2 1
8 14 1 1 3 2
9 4     4 3
10 29 2 2    
11 30     5 5
12 9 3 4    
13 28        
14 15 4 8    

In der Zelle C3 steht die Formel:

=WENN(ISTZAHL(B3);SVERWEIS(B3;Legende.xls!Martingale;2;FALSCH);"")

Die Formel ist schnell erklärt. Wenn eine Zahl in der Spalte "Progi-Stufe" (B3) steht, dann können wir für diese Stufe über SVERWEIS den entsprechenden Wert ermitteln.

  • 1. Parameter (hier B3) ist der Suchbegriff, in unserem Falle die Stufe
  • 2. Parameter (hier Legende.xls!Martingale) ist der zu durchsuchende Bereich. Dabei muss dieser immer aus 2 Spalten bestehen, in der ersten (ganz linken Spalte) wird der Suchbegriff (B3) gesucht. Wenn gefunden, dann kann auf alle Werte in der gefunden Zeile ab Index 2 (somit Spalte 2) zugegriffen werden.
  • 3. Parameter (hier 2) kennzeichnet den Spaltenindex, dessen Wert wir ermitteln wollen. Also in unserem Falle steht in der 2. Spalte der Wert der Progression. Wenn unser Suchbereich 3 Spalten hätte, könnten wir über die Spaltenindex 3 auf die entsprechenden Werte in dieser Spalte zugreifen.
  • 4. Parameter (hier FALSCH) gibt an, ob nach dem exakten Wert mit Suchbegriff in Spalte 1 gesucht werden soll. Wenn hier FALSCH steht, dann wird nur nach dem exakten Wert gesucht. Wenn hier Wahr steht, dann wird der Wert gefunden, der dem Suchbegriff am nächsten liegt und kleiner bzw. gleich dem Suchbegriff ist. Wenn z.B. als Suchbegriff nach 2 gesucht wird, aber im Suchbereich nur die Werte 1,5; 1,9 und 3,1 stehen, dann wird 3,1 als Ergebnis geliefert, da 2 <= 3,1 ist.

Die Formeln in der Spalte E entsprechend zu C. Kannst du dir ja in der obigen Tabelle anschauen, in dem du den Cursor auf die Zelle E3 setzt. Dann müßte eine QuickNotiz mit der Formel angezeigt werden (in IE auf jeden Fall, andere Browser weiß ich nicht).

Link zum Beitrag
Auf anderen Seiten teilen

Hi Chi,

nachdem Wenke schon "ausführlich" geantwortet hat, wage ich es trotzdem den Versuch, seine Antwort zu toppen

und das hast du geschafft, nichts gegen Wenke - seine Analysen sind immer korekt, aber die Erklärung war echt super toll!

:blink: BRAVO :crazy:

Du hast mir viel Arbeit ersparrt!

Gruß

David Cooper

- dein ewiger Bewunderer,

der sich schon jetzt auf dein nächstes

Posting freut -

Link zum Beitrag
Auf anderen Seiten teilen

@Chi Lu Jung

Das hast du aber sehr dezent ausgedrückt.

Meine 1. Ausrede: 01:34 Uhr ist nicht die richtige Zeit Excelprobleme zu erleutern.

Meine 2. Ausrede: Mir genügt der Hinweis, wo etwas auf andere Weise erkärt wird.

Alle Ausreden nutzen aber nichts, David Cooper hätte eine bessere Antwort verdient.

Deshalb versuche ich es jetzt so.

Zwei verschieden Antworten, sind auch nicht das schlechteste, was passieren kann.

Deine Antwort ist ganz schön schlau, und eröffnet viele Möglichkeiten. :crazy:

@David Cooper

Das du mit Hilfe von Chi Lu Jung eine Lösung gefinden hast ist richtig gut.

Damit wäre dieses posting überflüssig. Da es aber bereits fertig war,

und zwei Lösungen besser sind als eine, stelle ich es zusätzlich ein.

SVERWEIS erstellen

Ich gehe davon aus, das die Spalten EE und EF nicht benötigt werden

In ED1 trage Prog.Stufe ein

In EE1 trage Prog.Wert ein

Ab ED2 trage die Zahlen von 0 bis 30 fortlaufend ein

Ab EE2 trage die entsprechenden Proggressionssätze ein (E2=0,E3=1,E4=2,E5=4 usw.)

Klicke in die Zelle, in die der Einsatz eingetragen werden soll

Rufe den SVERWEIS auf

Bei Matrix trage $ED$2:$EE$500 ein

Bei Spaltenindex trage eine "2" als Zahl ein

Bei Bereich_Verweis trage FALSCH ein

Jetzt ist nur noch die Eingabezeile Suchkriterium offen.

Das ist die Zelle in welcher die Progressionshöhe berechnet wurde.

Anmerkung:

Die Werte für ED2 bis ED500 und EE2 bis EE500 lassen sich

später ergänzen oder ändern, ohne etwas an der Formel zu ändern.

Es stehen dir damit 500 Progressionsstufen zur Verfügung.

Für den Hausgebrauch etwas knapp, könnte aber reichen.

Mit besten Grüßen

Wenke

Link zum Beitrag
Auf anderen Seiten teilen

@David Cooper

Ich denke schon darüber nach. Jedoch will ich nächste Woche den letzten Teil der schönen Formeln bringen. Dort sollen die anderen Chancenteile eingebaut werden. Da ist schon die 1.Woche futsch.

Danach soll das Ganze von einem Makro erledigt werden. Das Makro soll etwa 100 Angriffe in einem Rutsch berechnen. Geschätzte Dauer ca. 2 Wochen.

Händische Berechnungen, trotz Vorlage, sind auch das Wahre. Mir sind dabei einige Fehler unterlaufen. Damit waren ein paar Monate Arbeit umsonst. Der Statistikteil fehlt auch noch.

Da bin ich voll eingespannt.

Irgendwie muss ich die Zeit doch einteilen.

Die bunten Zettel, die man gegen Wein, Weib, Gesang und Plasteteile eintauschen kann, findet man auch nicht auf der Straße.

Ich denke darüber nach.

Mit besten Grüßen

Wenke, der überlegt

Link zum Beitrag
Auf anderen Seiten teilen

Hallo Wenke,

ich hoffe wir arbeiten nicht doppelt.

Das Makro soll etwa 100 Angriffe in einem Rutsch berechnen. Geschätzte Dauer ca. 2 Wochen.

Ich entwickle gerade ein Add-In, das es ermöglicht, aus bielibig vielen Permanenzen (Vorlage sind die Hamburger Download-Permanenzen) automatisch eine Auswertung zu erstellen.

D.H. du wählst über ein Dateifenster deine gewünschten Permanzen aus, diese werden dann in deine Auswertungsdatei (von dir erstellte Excel-Datei mit Formeln) eingelesen und Tag für Tag ausgewertet. Die Ergebnisse (Saldo, Min, Max etc.) werden dann in ein Auswertungsblatt geschrieben. Dort werden sie gruppiert (z.B. nach Casino, Tischnummer nun Datum).

Eine erste Version werde ich im Laufe der nächsten Woche zur Verfügung stellen.

Link zum Beitrag
Auf anderen Seiten teilen

@Chi Lu Jung

Danke für deine Antwort. Natürlich interessiert mich das ganze sehr.

Wenn ich stat. Berechnungen anstellen will, muß das Ausgangsmaterial zumindest stimmen. Händisch gibt es zu viele Fehlermöglichkeiten.

Natürlich soll das ganze auch nicht zuviel Arbeit machen. Ich will ja nicht programmieren, nur auswerten. Deshalb Makros mit einigen Schleifen. Leider gibt es sehr wenig gute Literatur darüber. Daher "sammle" :crazy: ich Codeteile.

Ich betrachte es als Vorteil, wenn mehrere Arbeiten zu einem Thema vorhanden sind. Damit ist es möglich, den Teil zu nutzen, der einem besser liegt.

Wenn es fertig ist, stelle ich den Makrotext ein.

Beste Grüße und viele gute Ideen

Wenke

Link zum Beitrag
Auf anderen Seiten teilen

@ Chi

Sorry, muß dir mal wieder auf die Nerven gehen, weil ich mit meinem Latein schon wieder am

Ende bin.

Es geht immer noch um mein letztes Problem. Dein erster Lösungsvorschlag brachte das Problem,

daß dadurch die 0 zu einem „X“ wurde und damit die +/- - Spalte völlig verfremdete, jedoch

brachte mich dein Ansatz auf die Idee, eben auch „um die Ecke“ zu denken und ich habe es damit

gelöst, daß ich nicht mehr gefragt habe wann gesetzt werden soll, sondern wann KEIN Satz erfolgen soll. Und siehe da, plötzlich war’s ganz einfach...

Nur mit dem zweiten Teil, also Saldo auf 0 setzen, komme ich nicht weiter. Deine Lösung bringt nämlich das Problem, daß zwar der Saldo auf 0 gesetzt wird, wenn er im + war, nur wenn der Satz auch gewinnt (also 2 Gewinnsätze in Folge), Excel dies nun einfach ignoriert und den Gewinn nicht ausweist sondern eben stur eine 0 einträgt, also +2 wird erkannt, nächster Satz wäre wieder +2, aber nun sagt das Programm: neenee, soll ja 0 sein und basta.

Ich habe versucht es in den Griff zu kriegen, indem ich Spalten eingefügt und den +-Saldo dorthin übertragen habe um dann von dort aus weiterzurechnen etc. Erfolg: Ich kenne inzwischen wohl alle Fehlermeldungen, die Excel hat, von #WERT bis Zirkelbezug.

Noch ein Satz zu deiner Kritik: Gerade weil ich nicht nur Formeln abtippen sondern auch die Logik lernen möchte, habe ich deine Makro-Lösung damals nicht einfach übernommen, denn so weit, die zu verstehen, bin ich auch jetzt noch nicht.

Deshalb habe ich auch jetzt erst versucht, alleine zum Ziel zu kommen, und wenn ich Tagelang nur probiere, aber die Materie ist echt heftig wenn man sich damit noch nie beschaftigt hat. Und irgendwann rennt man eben immer wieder an die gleiche Wand weil man irgend einen dusseligen kleinen Fehler in der Logik nicht erkennt....

Danke schon mal im voraus. Ich überlege, ob ich mir ein Excel-Lehrbuch anschaffe, aber die Dinger sind wirklich schweineteuer.

Danke für Pulver

Shotgun

Link zum Beitrag
Auf anderen Seiten teilen

Hallo Shotgun,

erst einmal noch ein Hinweis von mir.

Ich habe nichts gegen Fragen und beantworte sie gerne!

Nur habe ich halt etwas Zeit gebraucht, um einzusehen, dass ich mit meinen Excel-Wissen und Erklärungen Anfänger erschlage. Ich hoffe, ich habe es nun kapiert und meine Antworten sind verständlich und umsetzbar.

Ein Lehrbuch zu kaufen ist nicht notwendig, du findest im Web tausende von Seiten, welche sich ausführlich mit Excel beschäftigen. Unter anderem auch "Lehrgänge". Also einfach mal über Google suchen.

Freut mich, dass du das Problem mit der 0 gelöst hast. Ich hätte es so gelöst, dass ich Spalte "Coups" auf die 0 anstatt die Spalte "Noir/Pair" abgefragt hätte.

So, nun das Problem mit dem Saldo. Ich hatte diese Konstellation leider nicht bedacht. Damit ich dir diesmal eine richtige Lösung serviere, sende mir bitte dein Excel-Spreedsheet per EMail zu. Ich könnte zwar versuchen, dein Spreedsheet "nachzubauen", ist mir aber zuviel Arbeit :crazy:

Also bitte Excel-Datei an [email protected]

Bis dann

:blink:

bearbeitet von Chi Lu Jung
Link zum Beitrag
Auf anderen Seiten teilen

Hi Chi Lu Jung,

momentan habe ich ein richtig großes Problem!

Ich wollte für Tottermann sein spiel programmieren, aber irgendwie komme ich da nicht so recht weiter!

Es werden verschiedene Chancen gleichzeitig bespielt, aber wenn ich jede Chance einzeln mit Ergebnis, Einsatz untersuche wird die Tabelle irgendwie zu breit!

Schau dir, wenn du Zeit hast, Tottermanns Posting an mich mal an, und schreibe mir, ob du noch eine andere Idee hast!

Gruß :crazy:

David Cooper

Link zum Beitrag
Auf anderen Seiten teilen

Hallo David,

ich stelle hier mal das bisherige Ergebnis meiner Arbeit ein. Wenn du mir kurz erklärst, wie die Aussage von Tottermann

Nach dem ersten Treffer des Spiels sind mindestens 5 Vorlaufcoup aus den bereits gefallenen Coup zu berücksichtigen. Wieder darf hierin keine Wiederholung der erschienenen Chancen vorkommen. Es werden aber nicht nur 5 sondern alle letzten Coup (Rückwärtspermanenz) ausschließlich der ersten Wiederholten Chance berücksichtigt.

zu interpretieren ist, werde ich mal schauen, ob ich das noch hinbekomme.

Formeln in den Zellen als QuickNotiz

" wurden durch ' ersetzt

m_point17.gif A B C D E
1 Coup Chance Chance 1 Chance 2 Auszahlung
2 0 1 1 1 35
3 1 2 2 2 35
4 2 3 3 3 35
5 3 4 4 4 35
6 4 5 5 5 35
7 5 6 6 6 35
8 6 7 7 7 35
9 7 8 8 8 35
10 8 9 9 9 35
11 9 10 10 10 35
12 10 11 11 11 35
13 11 12 12 12 35
14 12 13 13 13 35
15 13 14 14 14 18
16 14 14 14 14 18
17 15 15 15 15 9
18 16 16 15 16 27
19 17 16 15 16 27
20 18 15 15 15 9
21 19 17 17 17 18
22 20 17 17 17 18
23 21 18 18 18 9
24 22 19 18 19 27
25 23 19 18 19 27
26 24 18 18 18 9
27 25 20 20 20 12
28 26 20 20 20 12
29 27 20 20 20 12
30 28 21 21 21 12
31 29 21 21 21 12
32 30 21 21 21 12
33 31 22 22 22 12
34 32 22 22 22 12
35 33 22 22 22 12
36 34 23 23 23 12
37 35 23 23 23 12
38 36 23 23 23 12
39          
40          
41 Coups Chance1 Chance2 Signal  
42 1 2 2    
43 8 9 9    
44 23 18 19    
45 28 21 21    
46 35 23 23 satz  
47 22 18 19 kein satz  
48 13 14 14 kein satz  
49 33 22 22 satz  
50 24 18 18 kein satz  
51 30 21 21 kein satz  
52          

In dem ersten Teil der Tabelle wird den einzelnen Zahlen jeweils eine Chance 1 und 2 zugewiesen. Somit hat man die Möglichkeit, den Sonderfällen 16/17 und 22/23 zwei unterschiedliche Chancen zu zuweisen. Die Spalte "Auszahlung" dient dann zur Berechnung eines möglichen Gewinnes. Die Auszahlung beinhaltet das Satzstück und berücksichtigt für die Pleins den Tronc. Bei der späteren Saldoermittlung müssen dann die verlorenen Einsatzstücke abgezogen werden.

Der hellblaue Bereich hat den Namen "Chancen" bekommen.

Und hier mal die Formeln dazu:

m_point17.gif A B C D
41 Coups Chance1 Chance2 Signal
42 1 =WENN(ISTZAHL($A42);SVERWEIS($A42;Chancen;3);"") =WENN(ISTZAHL($A42);SVERWEIS($A42;Chancen;4);"")  
43 8 =WENN(ISTZAHL($A43);SVERWEIS($A43;Chancen;3);"") =WENN(ISTZAHL($A43);SVERWEIS($A43;Chancen;4);"")  
44 23 =WENN(ISTZAHL($A44);SVERWEIS($A44;Chancen;3);"") =WENN(ISTZAHL($A44);SVERWEIS($A44;Chancen;4);"")  
45 28 =WENN(ISTZAHL($A45);SVERWEIS($A45;Chancen;3);"") =WENN(ISTZAHL($A45);SVERWEIS($A45;Chancen;4);"")  
46 35 =WENN(ISTZAHL($A46);SVERWEIS($A46;Chancen;3);"") =WENN(ISTZAHL($A46);SVERWEIS($A46;Chancen;4);"") {=WENN(ISTZAHL($A46);WENN(UND(ISTFEHLER(MODALWERT(B42:B46));ISTFEHLER(MODALWERT(C42:C46)));"satz";"kein satz");"")}
47 22 =WENN(ISTZAHL($A47);SVERWEIS($A47;Chancen;3);"") =WENN(ISTZAHL($A47);SVERWEIS($A47;Chancen;4);"") {=WENN(ISTZAHL($A47);WENN(UND(ISTFEHLER(MODALWERT(B43:B47));ISTFEHLER(MODALWERT(C43:C47)));"satz";"kein satz");"")}
48 13 =WENN(ISTZAHL($A48);SVERWEIS($A48;Chancen;3);"") =WENN(ISTZAHL($A48);SVERWEIS($A48;Chancen;4);"") {=WENN(ISTZAHL($A48);WENN(UND(ISTFEHLER(MODALWERT(B44:B48));ISTFEHLER(MODALWERT(C44:C48)));"satz";"kein satz");"")}
49 33 =WENN(ISTZAHL($A49);SVERWEIS($A49;Chancen;3);"") =WENN(ISTZAHL($A49);SVERWEIS($A49;Chancen;4);"") {=WENN(ISTZAHL($A49);WENN(UND(ISTFEHLER(MODALWERT(B45:B49));ISTFEHLER(MODALWERT(C45:C49)));"satz";"kein satz");"")}
50 24 =WENN(ISTZAHL($A50);SVERWEIS($A50;Chancen;3);"") =WENN(ISTZAHL($A50);SVERWEIS($A50;Chancen;4);"") {=WENN(ISTZAHL($A50);WENN(UND(ISTFEHLER(MODALWERT(B46:B50));ISTFEHLER(MODALWERT(C46:C50)));"satz";"kein satz");"")}
51 30 =WENN(ISTZAHL($A51);SVERWEIS($A51;Chancen;3);"") =WENN(ISTZAHL($A51);SVERWEIS($A51;Chancen;4);"") {=WENN(ISTZAHL($A51);WENN(UND(ISTFEHLER(MODALWERT(B47:B51));ISTFEHLER(MODALWERT(C47:C51)));"satz";"kein satz");"")}

Über SVERWEIS wird für die einzelnen Coups die Chance1 bzw. Chance2 (im benannten Bereich "Chancen" Spalte 3 bzw. 4) ermittelt. Das Satzsignal ermittelt, ob in den letzten 5 Coups entweder in Chance1 oder Chance2 ein Wert doppelt oder mehrmals erschienen ist (MODALWERT). Wenn nicht, dann liefert MODALWERT den Fehler "#NV". D.h. wenn beide Chancen keinen "Modalwert" haben (also Fehler liefern), dann kann ein Satz getätigt werde, ansonsten eben nicht.

Wie du siehst, habe ich die Regel von Tottermann so interpretiert, dass in den letzten 5 Coups (Vorlaufcoups) KEINE Wiederholung einer Chance kommen darf. Wenn keine Wiederholung kommt, dann Satz. Aber ich denke, diese Regelauslegung ist falsch. Bitte um Aufklärung :crazy:

bearbeitet von Chi Lu Jung
Link zum Beitrag
Auf anderen Seiten teilen
Wie du siehst, habe ich die Regel von Tottermann so interpretiert, dass in den letzten 5 Coups (Vorlaufcoups) KEINE Wiederholung einer Chance kommen darf. Wenn keine Wiederholung kommt, dann Satz. Aber ich denke, diese Regelauslegung ist falsch. Bitte um Aufklärung

Die Auslegung ist richtig!

In der Tabelle vom 23.01. ist mir die Auszahlung unklar. Bis zur 14 ist sie ok. Bis 12 35 Stücke ab 13 18 Stücke aber auf alle Cheval 18 Stücke also alle zahlen von 13 bis 24 "ernten" 18 Stücke.

Alle Zahlen ab 25 "ernten" 12 Stücke.

Gruß

Tottermann

Link zum Beitrag
Auf anderen Seiten teilen

Hallo Tottermann,

danke für deine Hinweise.

Aber ich würde vorschlagen, wir warten auf David. Der soll das mal programmieren und ich kann dann bei Excel-Detailproblemen mit Rat und Tat helfen.

Am System an sich habe ich kein Interesse - getreu meinem Motto:

Verschwende keine Zeit mit starren Systemen :blink:

Ist halt meine Erfahrung, will aber keinen davon abhalten :blink:

Link zum Beitrag
Auf anderen Seiten teilen

Wie ist deine Meinung dazu?

Du kannst jetzt schreiben und dich später registrieren. Bereits registrierter Teilnehmer? Dann melde dich jetzt an, um einen Kommentar zu schreiben.
Hinweis: Dein Beitrag wird nicht sofort sichtbar sein.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Neu erstellen...